Submittals and RFIs not loading on web
Incident Report for PlanGrid
Resolved
This incident has been resolved.
Posted Nov 17, 2020 - 15:21 PST
Monitoring
PlanGrid’s engineering team has resolved the issue. Submittals and RFIs are functioning normally on the website. We appreciate your trust in us as we continue to make your success a top priority.
Posted Nov 16, 2020 - 14:56 PST
Investigating
PlanGrid is aware of the issue impacting Submittals and RFIs not loading on web. Our team is currently investigating it. Refreshing the page repeatedly may alleviate this issue.
Posted Nov 16, 2020 - 12:02 PST
This incident affected: Website.