Inability to open sheets from large projets on web.
Incident Report for PlanGrid
Resolved
PlanGrid’s engineering team has resolved the issue. Our website is functioning normally. We appreciate your trust in us as we continue to make your success a top priority.
Posted Mar 15, 2018 - 09:32 PDT
Monitoring
PlanGrid’s engineering team has resolved the issue. Our website is functioning normally. We appreciate your trust in us as we continue to make your success a top priority.
Posted Mar 14, 2018 - 09:24 PDT