Slowness on PlanGrid Web
Incident Report for PlanGrid
Resolved
This incident has been resolved.
Posted Dec 15, 2020 - 15:58 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 14, 2020 - 14:57 PST
Identified
Currently we are seeing slowness on our website. Our Engineering team is aware and working to resolve this as soon as possible.
Posted Dec 14, 2020 - 11:41 PST
This incident affected: Sheet Processing, Staple Packs, Task & RFI Reports, Asbuilts, and Website.