Field Reports from PDF not visible on web (Draft and Submitted)
Incident Report for PlanGrid
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 19, 2019 - 07:07 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. Aug 15, 2019 - 17:27 PDT
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Aug 15, 2019 - 14:33 PDT
This incident affected: Website.