PlanGrid Forms
Incident Report for PlanGrid
Resolved
This incident has been resolved.
Posted Apr 15, 2024 - 08:58 PDT
Update
We are continuing to investigate this issue.
Posted Apr 15, 2024 - 08:48 PDT
Investigating
We are investigating an issue with where customers are unable to view forms. We are actively looking into this and we will provide an update within 60 minutes or sooner if we have more information to share.
Posted Apr 15, 2024 - 08:48 PDT