Home page not loading
Incident Report for PlanGrid
Postmortem

AUTODESK EVENT ANALYSIS

Incident Number: # COE-INC107739
Incident Date: March 22, 2024

Summary

On March 22, 2024 between 9:22 AM PDT and 11:12 AM PDT, Autodesk became aware of an incident that impacted customers using PlanGrid. Specifically, users encountered "Internal Server Error" messages when attempting to access the ‘Home’ page within PlanGrid. This issue was only observed in the US region due to different versions of the homepage being used in other regions.

Impacted Services

  • PlanGrid in the US region.

Root Cause

The service disruption was caused by a recent settings change in PlanGrid Insights, which resulted in an internal error when verifying users' access. This caused a circuit breaker to open, disrupting communication.

Autodesk Actions

Autodesk has completed a post-incident analysis of the event and identified actions to be taken. These include the following:

  • A rollback was implemented to reverse the changes made by the recent deployment.
  • The servers were restarted, and the home page was confirmed to be loading correctly.
  • Autodesk will continue monitoring the situation to ensure the issue is fully resolved.

Thank you for your patience and understanding.

Posted Apr 01, 2024 - 17:37 PDT

Resolved
This incident has been resolved.
Posted Mar 22, 2024 - 11:12 PDT
Update
Our team has identified the issue and are working to resolve. There is a workaround where you can still access your PlanGrid project information by clicking on a module on the lefthand side navigational menu.
Posted Mar 22, 2024 - 10:49 PDT
Investigating
We are currently investigating this issue. Please be advised that only Home is affected and all other features are operational.
Posted Mar 22, 2024 - 10:24 PDT
This incident affected: Website.