Inability to Login
Incident Report for PlanGrid
Resolved
This incident has been resolved.
Posted 6 days ago. Feb 13, 2018 - 10:53 PST
Monitoring
PlanGrid's engineering team has resolved the issue. Users can log into plangrid.com. We appreciate your trust in us as we continue to make your success a top priority.
Posted 7 days ago. Feb 12, 2018 - 10:49 PST
Identified
At 10:25 AM PST, Users were unable to log into plangrid.com. We are taking aggressive steps to resolve the issue.
Posted 7 days ago. Feb 12, 2018 - 10:45 PST