General slowness on web
Incident Report for PlanGrid
Resolved
This incident has been resolved.
Posted Jul 25, 2022 - 13:10 PDT
Investigating
Our engineers are aware of and currently investigating the intermittent general slowness our website is experiencing.
Posted Jul 25, 2022 - 11:39 PDT
This incident affected: Website.