Inability to load the Plangrid.com website
Incident Report for PlanGrid
Resolved
This incident has been resolved.
Posted May 11, 2022 - 12:44 PDT
Update
We are continuing to monitor for any further issues.
Posted May 11, 2022 - 12:43 PDT
Monitoring
We are aware of the intermittent issues regarding our app.plangrid.com website. Our Engineering team has fixed the problem, but we will continue to monitor until we are confident they are resolved. We appreciate your patience as we work through this!
Posted May 11, 2022 - 11:57 PDT
This incident affected: Website.