Sheet upload slowness
Incident Report for PlanGrid
Resolved
This incident has been resolved.
Posted Aug 16, 2023 - 15:11 PDT
Investigating
We are aware of an issue impacting uploading sheets, where users can experience uploads being stalled. Our engineers are working on fixing this. Please check our Status Page for the most up to date information.
Posted Aug 16, 2023 - 14:12 PDT
This incident affected: Sheet Processing and Website.