Unable to login and slowness - 500 errors
Incident Report for PlanGrid
Postmortem

AUTODESK EVENT ANALYSIS

Incident Number: #COE-INC107020

Incident Date: February 20, 2024

Summary

On February 20, 2024 between 7:09 AM PST and 8:53 AM PST, Autodesk experienced a service disruption that impacted customers using PlanGrid in the US region.

Impacted Services

  • PlanGrid customers in the US region were unable to access or load projects.

Root Cause

  • An unusually high volume of requests caused a high CPU load that resulted in significant performance degradation that impacted PlanGrid projects.
  • While the issue was being investigated, the high volume of requests dropped and the issue self-resolved on February 20, 2024 at 8:53 AM PST.

Autodesk Actions

Autodesk has completed a post-incident analysis of the event and identified actions that have been taken. These include the following:

  • Implemented auto-scaling improvements for dependent services to mitigate future occurrences.
  • Improved alerting processes when large traffic spikes are detected to expedite resolution.

Thank you for your patience and understanding.

Posted May 30, 2024 - 10:57 PDT

Resolved
This incident has been resolved.
Posted Feb 20, 2024 - 09:52 PST
Investigating
Our team is aware of an issue where 500 errors or "something went wrong" appears when trying to login to PlanGrid or PlanGrid Admin Console on web, or navigating the site. We are currently working on a fix.
Posted Feb 20, 2024 - 09:07 PST
This incident affected: Website.