Incident identified with RFIs and Submittals
Incident Report for PlanGrid
Resolved
This incident has been resolved.
Posted May 17, 2022 - 13:19 PDT
Investigating
We have identified potential issues when editing RFIs and Submittals (Web, iOS, Andriod). We are currently investigating this incident.
Posted May 17, 2022 - 09:13 PDT
This incident affected: Mobile Syncing and Website.